After monitoring the situation over the past few hours, we can confirm that the immediate impact of the outage has been fully mitigated. Our services are stable, and network performance has returned to normal.
We will provide a more detailed post-mortem once we receive a conclusive report from Microsoft's Azure Operations Support (OSS) team.
Thank you for your patience and understanding. We sincerely apologize for any inconvenience this may have caused.
Posted Mar 18, 2025 - 23:35 EDT
Monitoring
We want to inform you that we recently experienced network degradation affecting our services due to an ongoing issue within Microsoft's Azure infrastructure in the East US region.
What Happened? According to Azure, between 13:09 UTC and 18:51 UTC, a fiber cut impacted network capacity in the region, leading to intermittent connectivity loss and increased latency. While Azure has since mitigated the issue, we observed disruptions in our own services between 7:20 PM and 8:27 PM (Eastern Time), specifically affecting connections between the Cigo Tracker web app and our Redis service.
Current Status As of 8:27 PM UTC, network latencies have returned to normal, and service stability has been restored. However, to ensure a prompt and complete resolution, we have escalated this matter to Azure's Operations Support with a critical priority.
We appreciate your patience and will continue monitoring the situation closely. If you experience any further issues, please reach out to our support team.
Posted Mar 18, 2025 - 20:44 EDT
This incident affected: Web applications (Dispatch Web Platform, Customer Tracker) and APIs (Public API, Operator API).