Degraded Platform Performance Due to Ongoing System Update

Incident Report for Cigo

Resolved

The issue has been fully resolved. We reverted the deployment that caused the disruption, and the related changes will be revised and rescheduled for a future release. Thank you for your patience and understanding throughout the investigation.
Posted Jun 23, 2025 - 17:00 EDT

Identified

We’ve identified the cause of the issue. While platform performance has recovered, the underlying system update did not complete successfully. Our team is conducting a thorough review of the root cause and will provide further updates as we determine the next steps.
Posted Jun 23, 2025 - 16:16 EDT

Investigating

We are currently investigating an issue related to an ongoing system update that is impacting platform performance and availability. Users may experience slow response times or intermittent access issues. Our engineering team is working to identify the root cause and restore full functionality as quickly as possible. We will share updates as progress is made.
Posted Jun 23, 2025 - 16:08 EDT
This incident affected: Web applications (Dispatch Web Platform, Customer Tracker), APIs (Public API, Operator API), Mobile applications (iOS, Android), and Services (Outbound Email Service, Outbound SMS Service).