System outage
Incident Report for Cigo
Postmortem

After reviewing this incident with the Microsoft Azure OSS (Operations support systems) team, the issue seemed to have been related to a 30 minutes outage between our Virtual Network and the Azure DNS (from between 1:45 pm and 2:15 pm EST or 18:45 and 19:15 UTC).

Based on the recommendations we were given, our operations team has made some initial configuration adjustments that should prevent this issue from re-occurring in the future. We’re also investigating and implementing additional fallbacks to continue to ensure the highest system availability possible.

We apologize for the inconvenience this may have caused to your operations, your fulfilment teams, and your end consumers.

Posted Feb 12, 2022 - 19:34 EST

Resolved
This incident has been resolved, and we will continue our investigation with our Cloud hosting provider to better grasp what happened, and how we can prevent it for the future.
Posted Feb 11, 2022 - 14:45 EST
Monitoring
The issue seems to have been resolved; we're still seeing some degraded performance as things stabilize. We've identified the cause of the issue, and will further investigate how to prevent it from re-occurring in the future. We apologize for the downtime experienced.
Posted Feb 11, 2022 - 14:21 EST
Investigating
We are experiencing a system outage, and are investigating the issue.
Posted Feb 11, 2022 - 14:13 EST
This incident affected: Dispatch Web Platform, Customer Tracker, Public API, Operator API, iOS, Android, Routing and Itinerary Optimization, Maps, Notifications, Outbound Email Service, and Outbound SMS Service.