Import Tool

Incident Report for Cigo

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 09:51 EDT

Update

9:15 AM EST — Investigating
We are investigating reports of delays and errors when importing jobs via the Import Tool. Some users may experience failed or slow-processing imports during this time.

9:41 AM EST — Resolved
This incident has been resolved. Import Tool functionality has returned to normal and all delayed imports have been processed. We apologize for any inconvenience.

Duration: 26 minutes
Posted Jul 27, 2026 - 09:47 EDT

Investigating

We are investigating reports of delays and errors when importing jobs via the Import Tool. Some users may experience failed or slow-processing imports during this time.
Posted Jul 27, 2026 - 09:46 EDT
This incident affected: Web applications (Dispatch Web Platform).